Timeline for Registration and Login: Best way to separate responsibilities
Current License: CC BY-SA 3.0
3 events
| when toggle format | what | by | license | comment | |
|---|---|---|---|---|---|
| Nov 12, 2014 at 21:56 | comment | added | Uri Agassi | @Bart - I believe that the name of the method - Register infers exactly what it does - everything necessary for registration. If you chose to call it CreateUserSendMailAndLogin you would have coupled the name of the method with the implementation - what would happen if you decided you should send an SMS instead of mail, should you change the name of the method? Should the caller know or care what needs to be done when registering? I believe not - if the action to be done is registering, the name of the method should be Register. | |
| Nov 12, 2014 at 17:11 | comment | added | Bart Calixto | Based on your valid point that what it does is control the flow of the registration process. Do you have any naming suggestion that reflect that in the code? Instead of customerService.Register(binding); Is there any preferable apporach for this kind of naming ? | |
| Nov 12, 2014 at 16:32 | history | answered | Uri Agassi | CC BY-SA 3.0 |