Skip to main content

You are not logged in. Your edit will be placed in a queue until it is peer reviewed.

We welcome edits that make the post easier to understand and more valuable for readers. Because community members review edits, please try to make the post substantially better than how you found it, for example, by fixing grammar or adding additional resources and hyperlinks.

Required fields*

6
  • 1
    In which situation would you use an anonymous subclass to initialise a hashmap then? Commented Feb 3, 2009 at 16:01
  • 6
    Never to initialize a Collection. Commented Feb 4, 2009 at 8:10
  • Could you explain why using a static initializer is a better choice than creating an anonymous subclass? Commented Jan 24, 2012 at 14:27
  • 3
    @rookie There are several reasons given in other answers favoring the static init. The goal here is to initialize, so why bring in the subclassing, except maybe to save a few keystrokes? (If you want to save on keystrokes, Java is definitely not a good choice as a programming language.) One rule of thumb I use when programming in Java is: subclass as little as possible (and never when it can be reasonably avoided). Commented Jan 26, 2012 at 14:14
  • @eljenso - the reason I generally favour the subclass syntax for this is that it puts the initialisation inline, where it belongs. A second-best choice is to call a static method that returns the initialised map. But I'm afraid I'd look at your code and have to spend a few seconds working out where MY_MAP comes from, and that's time that I don't want to have to waste. Any improvement to readability is a bonus, and the performance consequences are minimal, so it seems like the best option to me. Commented Apr 21, 2017 at 9:27