Skip to main content

You are not logged in. Your edit will be placed in a queue until it is peer reviewed.

We welcome edits that make the post easier to understand and more valuable for readers. Because community members review edits, please try to make the post substantially better than how you found it, for example, by fixing grammar or adding additional resources and hyperlinks.

Required fields*

3
  • 3
    Sometimes, especially after struggling with cantankerous APIs, I also like to express my feelings by naming functions like pleaseDoSomething() :) Commented Apr 10, 2017 at 16:25
  • @Andy It is a regular part of my refactorings by moving unknown code blocks to doBlackMagic() and hope it will be less confusing later. Commented Jul 16 at 7:28
  • I think the first way is far more readable and intuitive than the second. The second way is a very confusing way of using booleans, not to mention it's twice as verbose. Commented Jul 16 at 15:48